Thursday, March 1, 2012

SharePoint 2010 Data View Web Part - Unable to display this web part

This post covers yet another nightmare that I had faced while working on one of the "terrible" areas in SharePoint. Yes, the topic is on Data View Web Part. The reason why i call it "terrible" is not because its difficult to understand, but with DVWP one tends to run into problems which is difficult to solve OR the reason is unknown. The main reason for this is because, the error message which is shared is very generic.

I faced a similar problem sometime back and here it goes... Could be a limelight for few of them, facing the same issue.

Problem Description
The Data View Web Part inserted on a page displays an error message instead of displaying the actual content. The error message is

"Unable to display this web part. To troubleshoot the problem, open this web page in a Microsoft SharePoint Foundation-Compatible HTML editor such as Microsoft SharePoint Designer. If the problem persists, contact your Web Server Administrator. Correlation ID....."

We faced this issue after deploying the SharePoint Site from one location to another through Site Backup-Restore methodology AND the first time a NON-Site Collection Administrator logs in to the page where the web part is hosted. The very moment, when a site collection administrator logs in & logs off and then sign in again as the normal user, the error is no more there.

It wasn't just this. The error comes back again inconsistently. But every time, it gets resolved immediately after the swap of logins.

The log files were also not helping much. Below is a snapshot of what the log file message looked like.

"Error while executing web part: Microsoft.SharePoint.WebPartPages.WebPartPageUserException: Personalization has been disabled for this zone.     at Microsoft.SharePoint.WebPartPages.SPWebPartManager.ThrowIfCantModifyZone(String zoneID, Boolean throwIfLocked)     at Microsoft.SharePoint.WebPartPages.SPWebPartManager.ProcessZoneId(WebPart webPart, Boolean throwIfLocked)     at Microsoft.SharePoint.WebPartPages.SPWebPartManager.SaveChangesInternal(SPLayoutProperties layoutProperties, Boolean skipRightsCheck, Boolean skipSafeAgainstScriptCheck)     at Microsoft.SharePoint.WebPartPages.BaseXsltListWebPart.get_CustomizedXsl()     at Microsoft.SharePoint.WebPartPages.BaseXsltListWebPart.LoadXslCompiledTransform(WSSXmlUrlResolver someXmlResolver)     at Microsoft.SharePoint.WebPartPages.DataFormWe... 73266dea-1438-40f8-9996-3f57e13878e0
...bPart.GetXslCompiledTransform()     at Microsoft.SharePoint.WebPartPages.DataFormWebPart.PrepareAndPerformTransform(Boolean bDeferExecuteTransform) 73266dea-1438-40f8-9996-3f57e13878e0
Leaving Monitored Scope (DataBinding DataFormWebPart (Sales Communications)). Execution Time=1587.0504032229 73266dea-1438-40f8-9996-3f57e13878e0"

Here is a related link which explains the same problem, but solution is to remove and add the user to the security group OR to the site directly.
We tried with the same and it did not help us.

This error occurs when the "AllowPersonalization" property of the Web Part Zone is set to false and a user with less privilege tries to access the zone. This leads to the WebPartPageUsageException. This could be overcome by just setting the AllowPersonalization property to true.

NOTE: Please respond if anyone has a different thought on the whole topic :)

Thanks for reading!!


  1. This helped me greatly! Thank you! We tried everything from XSLT timer to leaning out the code. Nothing worked until your solution!

  2. Where can I find the AllowPersonalization property?
    I'm using SP2010

  3. I have followed this step, but it still not work. For my problem is that I I have 70 column in a list and I try to edit it in Sharepoint Designer when I viewed it it bring the error message below:
    Unable to display this Web Part. To troubleshoot the problem, open this Web page in a Microsoft SharePoint Foundation-compatible HTML editor such as Microsoft SharePoint Designer. If the problem persists, contact your Web server administrator.

    Correlation ID:77c17189-0b4d-4606-9e56-8cbaa722dc79

  4. It didn't work for me too, anyone has update on it. how to resolve this issue?

  5. did not work for me either.
    I have the same problem as tep; I have almost 140 columns; if I reduce the number of columns to less than 60 it works with no problem.
    Was anyone able to solve this??